Excalibur 11 problems on wet sand

Only for the discussion of all other Minelab models of metal detectors that do not have there own forum.
Koala
Posts: 2023
Joined: Thu Sep 12, 2013 2:47 pm
Location: Cheshire
Been thanked: 11 times

Re: Excalibur 11 problems on wet sand

Post by Koala » Wed Feb 11, 2015 11:06 pm

Not my machine but suspect the coil. Search of the interweb see a lot of problems with the coil especially the early blue ones.

I had a faulty ground wire on one of my coils and that would work on the dry but not wet sand. Mine would also fail on long wet grass.

The only easy way to prove it is to swap coils.

User avatar
Machinist
Posts: 2045
Joined: Wed Jul 06, 2011 9:47 pm
Location: DANVM
Been thanked: 3 times

Re: Excalibur 11 problems on wet sand

Post by Machinist » Wed Feb 11, 2015 11:22 pm

As above, the only time I have had trouble with beach machines it has been the coil. Worked fine on dry sand and over wet until water got on the coil then falsing all over the place. Tiny crack in the coil only visible under magnification.

Ray
It's all the Headless Hunters fault !!

Member of South Yorkshire MDC

beachboy70
Posts: 100
Joined: Mon Sep 01, 2014 1:21 pm
Location: South West

Re: Excalibur 11 problems on wet sand

Post by beachboy70 » Fri Jul 08, 2016 12:59 pm

Did the wet sand problem get solved if it worked ok on a different beach then there must be a problem with the area or the beach as said before, always good to hear the result of problems like that. Changing the subject a little i have been asked to change the coil on the Excalibur for a friend he is buying a new one so the one i shall change will not be used for the water so no problem there, my question is are the FBS coils compatible with this machine or are they a special coil only for this machine any help appreciated on this subject. beachboy

Post Reply

Return to “Other Minelab Metal Detectors Forum”

Who is online

Users browsing this forum: No registered users and 1 guest