X-terra 70, no sound on pinpointing.

Only for the discussion of the Minelab X-TERRA range of metal detectors within this forum.
Post Reply
danez123
Posts: 19
Joined: Sun Nov 21, 2010 10:51 am
Been thanked: 1 time

X-terra 70, no sound on pinpointing.

Post by danez123 » Thu Aug 30, 2018 9:27 am

Hi guys I am posting this for my son who bought the 70 a month ago secondhand and has been out with it twice, last time was yesterday afternoon.
When he came back he was not happy and told me that although detector was searching fine, it made no sound on pinpointing also the diagram was not presenting itself when pinpoint button was pressed.

Any help appreciated.
Thanks.


My equipment.

Makro Racer
Laser scout
Minelab pro finder 25.

danez123
Posts: 19
Joined: Sun Nov 21, 2010 10:51 am
Been thanked: 1 time

Re: X-terra 70, no sound on pinpointing.

Post by danez123 » Thu Aug 30, 2018 9:47 am

Forgot to say, it is using the standard coil.
My equipment.

Makro Racer
Laser scout
Minelab pro finder 25.

Ladybird66
Posts: 1535
Joined: Wed Apr 04, 2018 10:03 pm
Has thanked: 505 times
Been thanked: 1084 times

Re: X-terra 70, no sound on pinpointing.

Post by Ladybird66 » Thu Aug 30, 2018 9:57 am

Have you got the Manual. If you have go to page 27 and take note of the warning boxes, bottom right of the 1st page.
Could be the problem. If he’s pressing the pin point button while the coil is over the target it will blank it out.

I bought one and only used it for a couple of weeks ( bought an Equinox) so I didn’t really get to grips with it so can’t guarantee this will work, but worth a try.

danez123
Posts: 19
Joined: Sun Nov 21, 2010 10:51 am
Been thanked: 1 time

Re: X-terra 70, no sound on pinpointing.

Post by danez123 » Thu Aug 30, 2018 4:48 pm

Thanks Ladybird but no warning boxes showing up.
My equipment.

Makro Racer
Laser scout
Minelab pro finder 25.

Post Reply

Return to “Minelab X-TERRA Forum”