Problem with my Spectrum XLT

Topics related to Whites metal detectors here, Off topic posts will be removed.
Whites Videos
Post Reply
dylan1273
Posts: 71
Joined: Thu Nov 11, 2010 1:41 pm
Location: Hertfordshire

Problem with my Spectrum XLT

Post by dylan1273 » Sat Mar 26, 2011 12:50 pm

Hi, i went out this morning and had to stop as my machine went nuts,just constantly beeping every few seconds, when i load my search program the XLT wont AIR Balance at waist level i have tried the battery,cleaning under the coil cover, but still the problem persists , anybody know where i can send it for repair?



urban1
Posts: 231
Joined: Wed Oct 20, 2010 4:45 pm

Re: Problem with my Spectrum XLT

Post by urban1 » Mon Mar 28, 2011 1:13 pm

Send it to whites in scotland

steverangerover125
Posts: 170
Joined: Thu Dec 30, 2010 8:40 pm
Location: Coalville Leicestershire

Re: Problem with my Spectrum XLT

Post by steverangerover125 » Mon Mar 28, 2011 1:25 pm

If not I run a repair service for everybody on here, you post it and just pay for parts, also a donation to either help with the running of this site or to a mental health charity would be welcome :)

dylan1273
Posts: 71
Joined: Thu Nov 11, 2010 1:41 pm
Location: Hertfordshire

Re: Problem with my Spectrum XLT

Post by dylan1273 » Mon Mar 28, 2011 3:16 pm

Thanks for your offer steverangerover125, ive had the machine apart for quick inside inspection, nothing looking untoward, i have also sprayed a slight amount of wd40 around the coil connector incase any water has ingressed around that area and have tested the machine and it now works, so i will see how it holds out but if it does play up again i may well need your services, but i have got a gut feeling its the coil and not the machine.

dylan1273
Posts: 71
Joined: Thu Nov 11, 2010 1:41 pm
Location: Hertfordshire

Re: Problem with my Spectrum XLT

Post by dylan1273 » Wed Mar 30, 2011 3:41 pm

Thanks for the info, the connector plastic nut on the coil is very tight,could be risky to undo it, if it plays up again i will have no choice but to try and undo it. thanks again

Trainer
Posts: 113
Joined: Tue Jun 14, 2011 8:50 pm

Re: Problem with my Spectrum XLT

Post by Trainer » Tue Jul 19, 2011 6:18 pm

I had a similar problem with mine and it was still within the 2 year guarantee (Series e 1.1 model)
Whites said send it up to them which i did and they repaired it no probs.
I was told the coil had to be re calibrated
Had it back for 18 month now with no further probs.
Basically sounds like you cant do it yourself and would be best to let someone with the right equipment have a look
Best of luck with it regards Pete

Post Reply

Return to “Whites Forum”