Page 1 of 1

Minelab xterra 505 problem

Posted: Mon Sep 04, 2017 10:32 pm
by Robbiedarza
Hello there, I was wondering if someone could look at the video I have linked below please. My minelab xterra 505 is acting really strange. I turned the sensitivity down a bit today and it stopped but I'm not sure what's wrong with it

Many thanks

Rob



Re: Minelab xterra 505 problem

Posted: Mon Sep 04, 2017 11:01 pm
by Blackadder43
I'm gonna state the obvious here and say check inside the coil cover for something in there and clean that out....
Check your batterys are fully charged
Check all the leads that plug in and especially check the coil leade to make sure its not damaged
Check the coil for damage
Check all settings especially channels (not sure if channels are changeable on your machine)
Make sure your phone is switched off
Make sure you are not testing near power lines, buried cables, transmitters etc
If all else fails send it to someone to give it a service

Re: Minelab xterra 505 problem

Posted: Mon Sep 04, 2017 11:11 pm
by Blackadder43
After a bit of research it appears your machine has a "noise cancel channel" adjustment
People often underestimate how important it is to get this right
Page 11 of this pdf from minelab should help
http://www.minelab.com/__files/f/43350/ ... 20size.pdf

This book is actually a free ebook by quite a cool and knowledgable chap on the xterras, quite a find if i do say so myself

Re: Minelab xterra 505 problem

Posted: Tue Sep 05, 2017 8:27 pm
by Batman
Pylons, electric fences, underground cables or pipework, security alarm systems on nearby houses all can set your machine off chattering. My 705 does it from time to time but I knock the sensitivity down a notch or two until it stops chattering. Make sure you noise cancel properly too. Hope this helps. ::g

Re: Minelab xterra 505 problem

Posted: Wed Sep 06, 2017 10:48 pm
by Robbiedarza
Hello. Many thanks for all the help guys it's really helped me out.

Cheers. Robbie.